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1. Rysowanie topografii 

Rysowanie topografii rozpoczynamy od dodania nowego widoku typu layout do komórki inw 

w bibliotece (INWERTER), w której poprzednio rysowaliśmy schemat. Topografia (layuot) 

koniecznie powinna być w tej samej celi, co schemat, aby zapewnić spójność bibliotek. 

     

 

 

 

 

Zostanie otwarte okno edytora topografii Virtuoso Layout Editor: 

 

 

Z zasobnika warstw Layers wybieramy warstwy, z których będzie rysowana topografia układu.  

paski narzędziowe 

zasobnik warstw 

opis aktualnie wybranej komendy 

środek ukł. współrzędnych (0,0) 

współrzędne kursora i ich zmiana 
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Przed przystąpieniem do pracy z edytorem topografii należy ustawić kilka parametrów. W tym celu 

wybieramy z menu Options → Display oraz Options → Editor. Optymalne ustawienia są pokazane 

na poniższych rysunkach. 

 

 

 

 

Wciskamy Save To licząc na to, że wprowadzone zmiany zostaną zapamiętane. 

Istotne dla projektów hierarchicznych 
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2. Podstawowe funkcje edytora topografii 

Rysowanie topografii polega na odpowiednim umieszczaniu prostokątów reprezentujących stosowne 

warstwy, tak aby ta struktura pozwoliła na późniejsze wygenerowanie masek produkcyjnych i 

fabrykację układu. Poniżej przedstawiono tylko kilka podstawowych komend. 

 

 Wybór obiektu – dowolny kształt może być zaznaczony na trzy sposoby: 

o żółtą przerywaną linią – kształt może być zaznaczony (po kliknięciu na niego), 

o białą ciągłą linią – kształt został zaznaczony, ale nie wcześniej wybrano żadnej 

komendy, 

o żółtą ciągłą linią – kształt został wybrany i wykonuje się na nim jakaś operacja. 

 Rysowanie prostokąta: Create → Rectangle (skrót klawiszowy r) – wybieramy warstwę 

z palety po lewej, klikamy myszą (naciśnij i puść lewy przycisk) pierwszy narożnik 

prostokąta, przeciągamy mysz i kończymy wskazując (jeden "klik") drugi wierzchołek: 
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 Przesuwanie: Edit → Move (skrót klawiszowy m) – myszą wskazujemy obiekt (jednokrotnie 

klikając lewym przyciskiem) i przesuwamy go w nowe miejsce: 

 

  Zaznaczony obiekt jest „podświetlony” na żółto. 

 Zmiana rozmiarów – przeciąganie: Edit → Strech (skrót klawiszowy s): wskazujemy bok 

prostokąta (podświetlony na żółto), następnie klikamy i przesuwamy: 

 

Po umieszczeniu kursora nad jakąś krawędzią prostokąta jest ona zaznaczana żółtą przerywana linią 

– została zaznaczona do przeciągania (strech’owania). Wystarczy już tylko kliknąć i przeciągnąć 

w nowe miejsce.  

Jeżeli kursor pojawi się w środku prostokąta to jest on cały wybrany do strch’owania (podświetlone 

wszystkie krawędzie) i w efekcie można go całego przesunąć jak za pomocą komendy move. 
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 Kopiowanie: Edit → Copy (skrót klawiszowy c): wskazujemy obiekt (podświetlony), 

klikamy i przenosimy nowy, skopiowany obiekt w wybrane miejsce: 

 

    
 

Powyższe operacje mogą być również wykonywane na grupie obiektów, wybieramy je zaznaczając 

lewym przyciskiem myszy obszar lub klikając pojedyncze elementy lewym przyciskiem myszy 

z wciśniętym klawiszem Shift. 

 

 Linijka Edit → Ruler (skrót klawiszowy k): 

 

 

 

Skala jest podana w µm. Linijka jest obiektem, tak samo jak prostokąty i może być przesuwana, 

rozciągana, kopiowana itd.  
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3. Projektowanie topografii inwertra 

Projektowanie rozpoczniemy od narysowania tranzystora NMOS, ponieważ w technologii używanej 

na zajęciach podłoże jest typu P, zatem można na nim od razu wykonać tranzystor NMOS. Dla 

PMOS’a trzeba zmienić typ podłoża poprzez wytworzenie studni typu N. 

Dla przypomnienia poniżej przedstawiono widok poglądowy tranzystora NMOS. 

 

Projektując tranzystor należy narysować niezbędne warstwy pozwalające na wytworzenie obszarów 

drenu i źródła wraz z kontaktami do ścieżek metalowych oraz obszar bramki (tu polikrzemowej) i 

ewentualny kontakt polikrzem-metal dla doprowadzenia sygnału wejściowego. 

W celu narysowania tranzystora NMOS układamy warstwy: aktywną/dyfuzji (DIFF), warstwy 

n
+
 (NPLUS) oraz polikrzemu (PO1) – iloczyn logiczny tych trzech warstw definiuje obszar kanału 

tranzystora NMOS. 

Kolejność rysowania warstw nie ma znaczenia, gdyż w trakcie fabrykacji układu zapewniona jest 

właściwa kolejność procesów technologicznych. Istotne są wymiary prostokątów oraz ich wzajemne 

ułożenie, co jest określone w regułach DRC danej technologii. 

 

Poniżej przedstawiono layout tranzystora NMOS: 

 

 

 

W celu podłączenia drenu i źródła na powyższym rysunku umieszczono już kontakty (CONT) oraz 

otaczający je metal 1 (ME1). 

 

DIFF 

PO1 

NPLUS 
CONT 

ME1 

bramka polikrzemowa 
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Dodatkowo na całej powierzchni tranzystora trzeba narysować prostokąt z warstwy 

SYMBOL MMS. Jest to warstwa dla ekstraktora, informująca o tym, że tu jest tranzystor. Poniżej 

przedstawiono kompletny tranzystor NMOS: 

 

 

Tranzystor PMOS wygląda bardzo podobnie, ale składa się z warstw: aktywnej (DIFF), polikrzemu 

(PO1), implantacji p
+
 (PPLUS) i dodatkowo studni N (NWEL) oraz oczywiście SYMBOL MMS. 

 

 

Tranzystor PMOS z warstwą SYMBOL MMS: 

 

DIFF 

PO1 

PPLUS 
CONT 

ME1 
NWEL 
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Następnym etapem jest łączenie drenów i bramek tranzystorów tworząc wyjście i wejście inwertera: 

 

W zasobniku warstw włączono tylko używane warstwy oraz wyłączono wyświetlanie warstwy 

SYMBOL, dzięki czemu topografia inwertera jest bardziej czytelna. 

Teraz łączymy bramki i rysujemy ścieżkę polikrzemową jako wejście: 

 

tylko użyte 
warstwy 

Visible 
warstwa jest 

widoczna lub nie 

Selectable 
warstwę można 

zaznaczyć i 
edytować lub nie 
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Kolejnym etapem jest wykonanie kontaktów do polaryzacji podłoży tranzystorów. Źródło 

tranzystora PMOS łączymy z jego podłożem (czyli studnią) i zasilaniem. Źródło tranzystora NMOS 

łączymy z jego podłożem (czyli podłożem całego układu) i masą. Studnia i podłoże są 

słabodomieszkowane, żeby nie powstało w tym miejscu złącze Schotky’ego należy zwiększyć 

domieszkowanie. W miejscu kontaktu musimy narysować odpowiednie warstwy n
+
 i p

+
, oznaczające 

większy poziom domieszkowania.  

 

 

Poniżej przedstawiono kompletną topografię inwertera: 

 

NPLUS 
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Wszystkie potrzebne warstwy już są ale taka topografia może być nieczytelna dla człowieka, 

zwłaszcza w przypadku bardziej skomplikowanych układów. Powyższy rysunek należy jeszcze 

uzupełnić o etykiety. Z menu wybieramy Create → Label (skrót l ), co spowoduje otwarcie okna do 

definiowania etykiet: 

 
 

Wpisujemy nazwy etykiet oddzielone spacją, wybieramy rozmiar i ewentualnie czcionkę tekstu oraz 

warstwę na której ma być umieszczona etykieta zaznaczając albo Use current entry layer albo 

Select layer. Wykrzyknik w nazwie oznacza etykietę globalną (tu: vdd! i gnd!): 
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Teraz możemy kolejno układać etykiety pamiętając żeby je "przypiąć" do właściwych warstw. 

W  centrum nazwy jest mały plus, który wskazuje miejsce "przypięcia" etykiety. Rysunek poniżej 

pokazuje właściwie poukładane etykiety. 
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4. Weryfikacja DRC 

Kolejnym etapem projektowania jest sprawdzenie poprawności narysowanych warstw, czyli 

sprawdzenie geometrycznych reguł projektowania.  

W tym celu z menu wybieramy: Assura → Run DRC: 

 

 

W tym oknie należy wybrać: Technology: UMC_18_CMOS oraz Rule Set: DRC. Należy też 

wpisać nazwę weryfikacji (Run Name) oraz katalogu (Run Directory), w którym będą zapisane jej 

wyniki (np. tak jak na powyższym rysunku). 

Jeśli weryfikacja przebiegnie pomyślnie na ekranie pojawi się komunikat: 
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W przeciwnym razie pojawi się okno z informacją o znalezionych błędach: 

 

 

W oknie Error Layer Window, za pomocą przycisków ze strzałkami, można przeglądać błędy. 

Aktualnie omawiany błąd jest podświetlany na layoutcie na różowo lub inne kolory. 

Zestaw reguł projektowych można znaleźć w dokumentacji dostawcy technologii. 
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5. Weryfikacja LVS (Layout-Versus-Schematic) 

Porównanie narysowanej topografii ze schematem jest bardzo ważnym etapem projektowania. 

Pozwala sprawdzić czy zaprojektowany layout jest zgodny z wcześniej zaprojektowanym schematem 

z punktu widzenia połączeń elektrycznych oraz parametrów elementów np. wymiary tranzystorów. 

Ponadto, w tej wersji Design Kitu, wyniki weryfikacji LVS są potrzebne dla ekstraktora. 

W celu wykonania weryfikacji LVS z menu wybieramy: Assura  Run LVS, w którym trzeba 

ustawić stosowne parametry: 
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Jeżeli porównanie przebiegło poprawnie to pojawi się okno z następującym komunikatem: 

 

 

 

W przypadku niezgodności pojawia sie okno informujące o zakończeniu porównania i zawierające 

szczegółowy raport różnic (w tym przypadku niezgodne są parametry jednego z tranzystorów): 
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Po naciśnięciu OK pojawi sie następne okno pozwalające na debagowanie błędów LVS (różnic 

między schematem a topografią): 

 

W lewej części zaznaczamy celę, w prawej rodzaj błędu i naciskamy Open Tool: 

 

Możemy teraz znaleźć poszczególne błędy na schemacie lub topografii odpowiednio wybierając 

w powyższym oknie. Prowadzi to do podświetlenia odpowiedniego elementu: 

 

W ten sposób należy znaleźć i poprawić wszystkie błędy (różnice na layoucie), tak aby topografia 

odpowiadała schematowi.  



Laboratorium Projektowania Systemów Scalonych 

 

KE AGH  str. 18 

6. Ekstrakcja 

Z utworzonej topografii można wyekstrahować schemat elektryczny układu w postaci listy połączeń 

(netlista) zawierający tranzystory oraz inne elementy, również pasożytnicze pojemności, rezystancje 

i indukcyjności. Warunkiem poprawnej ekstrakcji jest wcześniej poprawnie wykonana analiza LVS. 

W celu wyekstrahowania netlisty z menu wybieramy: Assura  Run Quantus QRC. Pojawi się 

okno jak poniżej, w którym trzeba ustawić kilka parametrów. 

W zakładce Setup wybieramy technologię UMC_18_CMOS oraz typ pliku wyjściowego 

Extracted View. 

 

 

 

Proszę zwrócić uwagę na to, aby odznaczyć Enable CellView Check. 
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W zakładce Extraction wybieramy typ ekstrakcji (np.: C Only) oraz wpisujemy nazwę węzła 

odniesienia (Ref Node), najlepiej masę: gnd! 

 

 

 

O zakończeniu ekstrakcji powodzeniem program poinformuje w następującym oknie: 
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W naszej bibliotece (INWERTER) pojawi się nowy widok dla projektowanej celi: 

 

 

Widok av_extracted może być otwarty za pomocą edytora layoutów. Klikając na niego dwukrotnie 

zobaczymy podobny widok do poniższego. 

 

Widoczne są ścieżki oraz wyekstrahowane elementy przedstawione jako komórki. Aby zobaczyć ich 

zawartość należy odpowiednio ustawić poziomy wyświetlania w oknie Display Options. Z menu 

wybieramy Options  Display… (skrót klawiszowy e): 
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Ponadto, aby zobaczyć siatkę połączeń w tym samym oknie (Display Options) zaznaczamy Nets. 

Poniżej przedstawiono fragment poprzedniego widoku po zmianach ustawień opcji wyświetlania. 

 

 

 

 

 

 

7. Symulacja po ekstrakcji (post layout’owa)  

Symulacja schematu uzyskanego z ekstrakcji pozwoli ponownie zweryfikować poprawność działania 

układu oraz przybliży pracę układu do rzeczywistości o ile zostaną uwzględnione elementy 

pasożytnicze wyekstrahowane z topografii. Będziemy korzystać z poprzedniego schematu do 

symulacji inwertera (inw_tb) ale zamiast netlisty z pierwszego schematu inwertera (symulowanego 

przed rysowaniem topografii) do symulacji będzie wzięta netlista po ekstrakcji. Do tego potrzebny 

jest plik konfiguracyjny reprezentowany przez widok config w bibliotece. Dzięki konfiguracji 

możliwy jest wybór różnych widoków poddanych symulacji i mogą być one niezależnie wybierane 

dla różnych elementów w większym układzie. 

Najpierw musimy utworzyć nowy widok w naszej celi inwertera w Library Manager wybieramy 

File → New → Cell View… 
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W oknie New File wybieramy View config, który jest otwierany przez Hierarchy Editor: 

 

 

 

Po naciśnięciu OK otwiera się okno edytora hierarchii. W oknie New Configuration zmieniamy 

widok na schematic oraz naciskamy przycisk Use Template: 
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Powoduje to otwarcie okna Use Template, w którym wybieramy spectre: 

 

 

 

Po naciśnięciu OK w poprzednim oknie (New Configuration) ustawienia zostaną zaktualizowane, co 

zatwierdzamy klikając OK. 

Teraz okno edytora hierarchii po uzupełnieniu i odczytaniu danych wygląda następująco: 
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W kolumnie View Found można zmienić widok poszczególnych komórek wczytanego schematu. Dla 

celi naszego inwertera zmieniamy widok ze schematic na av_extracted naciskając prawym 

przyciskiem myszy w kolumnie View To Use i wybieramy odpowiednio z listy rozwijanej: 

 

 

Teraz należy jeszcze zapisać ustawioną konfigurację (o czym informuje napis na górnym pasku okna 

– Save Needed). Na pasku narzędziowym okna naciskamy ikonę kartki z czerwoną strzałką, by 

uaktualnić ustawienia: , po czym w okienku jak poniżej, program zapyta co uaktualnić, a ikona 

kartki zmieni się na kartkę z niebieską strzałką: . 

 

 

 

Teraz można już zamknąć okno edytora hierarchii, a w menadżerze bibliotek klikamy dwa razy 

widok config i otworzy się następujące okno: 
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Ponieważ konfigurację już ustawiliśmy i nie potrzebujemy jego okna, wystarczy schemat do 

symulacji więc klikamy OK, co spowoduje otwarcie okna ze schematem do symulacji (inw_tb): 

 

 

 

Symulacje przeprowadzamy analogicznie do opisanych w instrukcji dotyczącej schematu. Jeśli nie 

zmienimy parametrów źródeł, to możemy zaobserwować wpływ wyekstrahowanych elementów 

pasożytniczych na pracę układu w warunkach jak poprzednio. 


